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Analyzing 2D Western Blots in just 5 Steps
Setup Project
Setup a Western Blot project, import and arrange the images in predefined groups.

Warp Images
Choose the 2D Western Blot Warping Strategy.

Detect and Quantify Spots
Create a Fused image containing Total Protein (gel) and Western Blot (signal on
membrane). Detect spots and transfer the consensus spot pattern to both.

Analyze Total Protein and Blot
Find interesting spots by setting filters, or select manually.

Present Results
Use the Western Blot report to show coverages, reproducibility and many more
features.
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What's so special about 2D Western Blot projects?
Due to the quite different looks of Western Blots and gel images, it is not so easy to align
these two image types for differential analysis. With a little workaround, this still becomes
possible: by using support images, which are not analyzed themselves, but support a
better alignment of the actual images. We use the outer shape of the membranes to align
those images, whose signal pattern is not comparable. Therefore, to align one Western
Blot to the gel image it is derived from, we need a set of 5 images:
1. Total Protein Gel
actual gel image of the total proteins

2. Total Protein Membrane
image of the membrane after blotting with protein pattern, easy alignable to the gel image

3. Total Protein Membrane Contour
image of this membrane after blotting, focuses on the contour, alignment is identical to 2.

4. Western Blot Contour
image of the membrane after the 2nd antibody incubation for the contour, can be aligned easily to
the contour image 3.

5. Western Blot 1 (up to 3 possible)
image(s) of this membrane after the 2nd antibody incubation (antibody signal), alignment is
identical to contour image 4.

While image 5 is the the Western Blot and image 1 the actual gel image, we want to
align it to, images 2 to 4 have the role of support images for a precise guidance from
5 to 1.
Delta2D's special project setup now considers the different functions of the images and
treats every image according to its role in this setup. To identify the role of an image,
Delta2D looks for the role names Total Protein Gel, Total Protein Membrane, Total Protein
Membrane Contour, Western Blot Contour, and Western Blot 1 (optionally also Western
Blot 2 or Western Blot 3).
Depending on your project setup, this can be in two places:
1. If there is only one set of 5 images in the project, and these images are distributed
according to their roles on 5 groups with exactly these names, this is distinct enough
for Delta2D to recognize the roles.
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2. If you prefer a different grouping, e.g. all images in one group, or you want your
groups to have different names, Delta2D uses the sample assigned to each image to
identify its role. In this case it is crucial, that you assign each image to the correct
sample.
On creating a project of the type "2D Western Blot", Delta2D always tries to do the
assignments during the image import procedure automatically on the basis of the image
names. Please check the proposals in the respective fields of the Import Wizard.

Multiple Sets in one Project
Of course you can have multiple sets of this kind in one project. In this case, Delta2D not
only has to be aware of the role of each image, but also to which set it belongs. The set is
determined by the image attribute "Gel". Hence it is important, that
•

all images belonging to one set have to be assigned to the same Gel.

Advanced Techniques
If you want to include multiple (up to 3) Western Blots in one set, Delta2D needs
additional information:
•
•

The Western Blots 1to 3 have to be assigned to different channels.
When using also multiple Western Blot Contour images (role 4), they have to be
assigned to the same channel as their corresponding Western Blots:
Western Blot Contour 1: Channel 1, Western Blot 1: Channel 1
Western Blot Contour 2: Channel 2, Western Blot 2: Channel 2
Western Blot Contour 3: Channel 3, Western Blot 3: Channel 3
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Setup Project
Create a new data pool
3. Click on the button 'Change Pool' and navigate to a folder where you want to store
your new pool.
4. Right click and select 'Create Folder', then click on the new folder to rename it. Type in
a name for your new pool.
5. Click on
and confirm the following dialog with
.

Create and open a new project
The 'Projects' dialog appears again showing an empty list of available projects.
1. Click on the
button to create a new project.
2. Provide a name for your new project, author and choose “2D Western Blot” as type.
Confirm with
.

Delta2D's Projects dialog.

3. Select the new project from the list and press

.
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Import the images to the respective groups

Step 3: Details of each image to import

1. In step “Setup Project” of the Workflow
click on the 'Import...' link.
2. Switch to the respective location and
select all images you want to import. Click
on
to proceed to the first image.
3. Eventually edit the name, and make sure
the image is assigned to its appropriate
sample:
- Total Protein Gel,
- Total Protein Membrane,
- Total Protein Membrane Contour,
- Western Blot Contour, or
- Western Blot 1/2/3.

4. If necessary, apply basic manipulations such as rotating, inverting or de-speckling to
the image.
5. Click on
and repeat steps 3 and 4 for every image.
6. Click on
to save assignments and close the dialog. The images will be automatic
sorted into the groups, which are automatically created on choosing this project type.
NOTE:
The correct assignment of the images is crucial for this special project setup. If done during the
import process, all images are sorted automatically into the respective groups. If you missed this
step, you can resume it by clicking on " Image Attributes" in the workflow. Switch to the "Sample"
tab in the "Image Attributes" dialogue, and drag the respective image to the desired sample and
drop it there.
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Warp Images

Two gel images, overlaid into a dual
channel image, not warped.

Two gel images, overlaid into a dual channel image,
after warping. Differences in expression levels are
clearly visible.

Define a warping strategy
1. Switch to the second step of the 'Workflow' called 'Warp Images'.
2. Click on the 'Warp Strategy' link to open the 'Warping Strategy Manager'.
3. Select the '2D Western Blot Warping Strategy' and confirm the default settings
with
.

Delta2D's Warping Strategy Manager.

4. Open the 'Warping Setup' window by clicking on the link 'Setup direct warpings' in the
Workflow. It should look similar to the following image:
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Warping Setup window after applying the 2D Western Blot Warping Strategy.

Use Delta2D's Automatic Warping
1. If the 'Job Manager' is not visible click on the 'Job Manager' link.
2. Just click the 'Start' button
automatic warping jobs.

in the 'Job Manager'. It will monitor and perform all

Review Warpings
1. Double-click on a row in the table below
'Review Direct Warpings' where the
symbol looks like .
2. A 'Dual View' window opens and shows
the overlay of the respective two images.
3. Please also check if the image background
has been hidden by using the 'Show/Hide
Review direct warpings (Step 2 of the Workflow).
Background' button ( ) in the tool bar.
4. Review the automatic warping between Total Protein Gel and Membrane, as well as
the 2 contour images. While Total Protein Gel and the Membrane should overlay the
spot patterns best possible, the two contour images should simply match their shape.
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Note:
To work with match vectors, select the Match Vector Tool
in the left vertical tool panel of the
Dual View.
To ease the use you might want to switch on "Snap Match Vectors To Spots". This can be done at
'Tools' > 'Options' > 'Delta2D' > 'Match Vectors'. Temporarily switch it off with CTRL key.

If there are regions where vectors seem to be incorrect, you can set and change all match
vectors manually:
•
•
•
•
•

Select a vector – just left-click on the vector.
Select multiple vectors – drag a rectangle with the mouse (keep the left mouse
button pressed). All vectors in that rectangle will be selected.
Delete match vectors – right click on a vector and select 'Delete' or 'Delete
Selected'.
Set a new match vector – first click on the spot in the orange, then on the
corresponding spot on the blue image.
Change a match vector – drag one end of the vector to change its position.

Note:
You can undo match vector operations by clicking the 'Undo' button

.

Click on the
button to apply your new vectors. You can iteratively add, correct or
delete match vectors until the result is satisfying.
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Detect and Quantify Spots
Generate a fusion image
1. Switch to the workflow step called 'Detect and Quantify Spots' and click on the 'Fuse
images' link to open the 'Image Fusion' dialog.
2. Click on
to use the default settings (Total Protein Gel and WB signal images) and
let Delta2D create a new image.

Detect spots on the fusion image
Click on the link 'Detect Spots on Fused Image...' in the Workflow.
After detection is finished, the fused image will appear with detected spot boundaries.

Edit spots on the fusion
1. Open the new fusion image by clicking on 'Open Fused Image using Max ....'.
2. A 'Dual View' window opens showing the single view of the fused image only.

Adding a new Spot

Note:
Select the 'Spot Editing Tool'
in the left
vertical tool panel in the Dual View to edit
spots.
We strongly recommend to edit spots ON
THE FUSION IMAGE ONLY.

Image region before / after adding a spot.
(Just click on the center of an undetected
spot to add it.)

Splitting a Spot

Joining Spots

Two spots, detected as one and split.
(Click once into the center of the spot that was
not detected separately).

Example for joined spots.
(Drag a line from one spot center to the other.)
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Move Spot Markers
Spot markers can be moved by dragging with the left mouse button.

Delete Spot Markers
To delete a spot marker you can right-click on it.

Remove Spots
1. Activate the 'Spot Selection Tool'
and select one spot or a group of spots.
2. Right-click and select 'Cancel Spot' / 'Cancel Selected Spots'.
To see all canceled spots with dotted line spot boundaries, select 'Spots' > 'Show
Canceled Spots' from the Dual View's menu.
NOTE:
You can easily assess a spot with the help of the 3D view (Dual View menu → Rollups --> Rollups -->
3D spots). Switch to the Spot Selection Tool and click on the spot or in the region you want to
inspect.
In the overlay of Fused and Western Blot image you can directly add spots on the Fused image.

Transfer Spots
1. In the Workflow step 'Detect and Quantify Spots' click on the link 'Transfer Spots
from Fused Image...'.
2. The 'Transfer Spots' dialog opens. Confirm the default settings with

.

Spot boundaries after spot transfer. Choose the 'Gel Image Regions' link in the workflow to open
this view. The essential spot pattern is the same on all gels, making 100% spot matching possible.
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Analyze 2D Western Blot vs Total Protein image
Filtering for AB signal vs. Total protein
Note:
The Quantitation Table is synchronized with all other views of Delta2D: Selecting an expression
profile in the table will select the spot e. g. in the Dual View.

To calculate the coverage we have 3 different kind of spots:
•
•
•

only present (unmatched) on the total protein gel image
only present (unmatched) on the WB image
matched on both images.

Click in the Workflow step 4 on Quantitation Table to open this table. To show or hide
the parameter, click on the Eye
and choose the respective parameters by activating the
checkbox below the name for all images and confirm this with
. The Quantitation
Table will be automatically refreshed.

Control Visibility of Images and Spot Data

To define matched spots, the rest of the spots must be cancelled or filtered. Choose one
of the parameter, sort the values by size, and use the filter (above the column) to enter
border values.
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Available parameters are
• Volume V ( sum of gray values within the spot boundary)
• normalized volume %V (ratio spot intensity to total intensity of the image)
• area A (of the spot boundary in pixel)
• average Avg (Volume / area)
If you want to select the spots manually, you can use the
• 3D view (Dual view menu “Rollup” → Rollups --> 3D view and
• Select Spots in the Dual View
To cancel spots (e.g. in the Western Blot image) select them e.g. in the Dual View, open a
Quantitation Table for this image (in the Light Table right mouse click on Western Blot
image and choose “Open Quantitation Table”) and click in the menu “Cancel” → Rollups --> Cancel
Selected Spots.
NOTE:
If you want to keep few spots and cancel the rest, you can use the inverse procedure: select the
wanted spots in the Dual View, open the Quantitation Table for this image, and choose from the
table's menu successively: Edit → Rollups --> Invert selection; Cancel → Rollups --> Cancel selected.

To filter spots among a certain parameter:

Filter Dialog for normalized volume %V

spot boundaries.

1. Click on the top part of the column header
labeled 'Filter'.
2. Insert the upper and lower filter borders
'Show values from'.
3. The 'Filter active' will be checked
automatically, additionally check the box
'Negated'. The latter will change the filter
dialog's text to 'Hide values from'. Confirm
with
.
4. Open the 'Dual View' with the two images
Only spots meeting our criteria will still have
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Present Results
Create special 2D Western Blot Reports
In step 5 “Present results”, under Reports click on

2D Western Blot.

You can choose between:
•
•
•

Using filters: The different paramters, lower and upper values set in Delta2D are
shown,
Using cancelled spots also defined in Delta2D's, or
Using predefined parameters directly in the report (Delta2D settings have no
impact)

Enter a remark, check the filter settings (if applicable) and confirm your entry with

.

Save and print this report
To save and print the report please click on
on the top right corner of the
report. After choosing a location and successful saving the button change into “Print”.
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Where Can I Find Out More about Delta2D?
The easiest way to learn more is going to http://www.decodon.com or contacting us per
Email to support@decodon.com. We will be happy to answer your questions or to show
you more in a live web demo.
Note:
If you need more detailed information about Delta2D, please consult the manual of Delta2D. You
can access it through the Delta2D menu 'Help' > 'Help …', or as a PDF file located in the
installation directory. In Windows, there is a direct link to the manual in the Start menu. The
manual is also available on our website for download and for online browsing!

Your DECODON Team

If you have any comment or suggestion regarding this 'Getting Started with Delta2D
Guide' or any other of our documents we welcome hearing from you.

